Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 5 of 5
  1. #1
    New Coder
    Join Date
    Jun 2009
    Posts
    12
    Thanks
    3
    Thanked 0 Times in 0 Posts

    Exclamation CSS:Background image not showing

    In FF & many others you can see the blue background in the sidebar i have, however this doesn't work in IE and only shows a white background which doesn't help as the color of the text is #ffffff.

    Code:
    #statsbar2{
    background: url('http://ibbuk.host56.com/statsbg2.jpg')no-repeat #00FFFF;
    color:#ffffff;
    margin-bottom:4px;
    }
    My demo site = http://www.ibbuk.co.uk./12/
    Last edited by jimmytubbs; 06-11-2009 at 04:45 PM.

  • #2
    Senior Coder
    Join Date
    Feb 2009
    Location
    Ilkley, West Yorkshire, UK
    Posts
    2,956
    Thanks
    9
    Thanked 727 Times in 721 Posts
    Look exactly the same turquoise colour/white text to me in FF3, IE7 and IE6.

  • #3
    New Coder
    Join Date
    Jun 2009
    Posts
    12
    Thanks
    3
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by SB65 View Post
    Look exactly the same turquoise colour/white text to me in FF3, IE7 and IE6.
    Try now ( the turquoise colour was something i was testing)

  • #4
    Senior Coder
    Join Date
    Feb 2009
    Location
    Ilkley, West Yorkshire, UK
    Posts
    2,956
    Thanks
    9
    Thanked 727 Times in 721 Posts
    Nah, can that, my eyes need testing.

    The problem is here:

    #statsbar2{
    background: url('http://ibbuk.host56.com/statsbg2.jpg')no-repeat;
    color:#ffffff;
    margin-bottom:4px;
    }

    Try a space after your closing bracket and before no-repeat. IE's obviously more picky than FF in this case. You have a lot of errors in your css, by the way.

  • #5
    New Coder
    Join Date
    Jun 2009
    Posts
    12
    Thanks
    3
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by SB65 View Post
    Nah, can that, my eyes need testing.

    The problem is here:

    #statsbar2{
    background: url('http://ibbuk.host56.com/statsbg2.jpg')no-repeat;
    color:#ffffff;
    margin-bottom:4px;
    }

    Try a space after your closing bracket and before no-repeat. IE's obviously more picky than FF in this case. You have a lot of errors in your css, by the way.
    Cheers that fixed it


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •