Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 3 of 3
  1. #1
    New to the CF scene
    Join Date
    May 2009
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    IE image shifting issues

    Hey hey forum!!!

    I'm pretty new to website coding but trying to make a go of it, and having some serious issues with IE

    www.allfiredupinc.com

    Why do I have to put a hack in to correct the image position in the sidebar LI elements under IE? And, why isn't the pixel spacing consistent between workstations (on my widescreen display images are shifted more than on a standard monitor)? It works fine in FF without the LI image position hack?

    ul#sidebar_nav li {margin-left:-15px;}


    I bet I'm not clearing something or floating wrong. This has been bugging me for weeks!!! Any insight anyone has is soooooo appreciated!!!

  • #2
    Senior Coder
    Join Date
    Feb 2009
    Location
    Ilkley, West Yorkshire, UK
    Posts
    2,956
    Thanks
    9
    Thanked 727 Times in 721 Posts
    Hi there

    The issue in IE7 (at least) is coming from the code:

    Code:
    <ul id="sidebar_nav">
    <li class="nav_party"><a href="party.html">Party With Us</a></li>
    ....
    </ul>
    In IE7 the <a> tag is indented from the <li> - so the background image is correctly aligned on the <a> tag but the <a> tag is indented. IE is leaving a space for the bullet even though one isn't displayed -caused by the css inherited from:

    Code:
    #container ul {
    	list-style: none inside;
    	}
    which applies the "inside" value to ul#sidebar-nav. You can see this using the IE Developer toolbar - this can be useful for debugging this sort of thing.

    You could try adding:

    Code:
    #container ul#sidebar_nav{list-style:none outside}
    to your css, and see how that looks. I guess IE and FF treat this slightly differently which is why it's OK in FF anyway.

    Hope this helps....

  • #3
    New to the CF scene
    Join Date
    May 2009
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Yarp! That was the trick. Thanks sooooo much! +1 Internets for you!

    Going to install that IE Developer toolbar you recommended as well...have FireFox developer tools already but IE makes me insane o_O

    Thanks again


  •  

    Tags for this Thread

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •