Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 4 of 4
  1. #1
    Senior Coder o0O0o.o0O0o's Avatar
    Join Date
    Jan 2008
    Location
    C:\Windows\System32
    Posts
    1,018
    Thanks
    19
    Thanked 9 Times in 9 Posts

    SWF file in loading on every page in firefox

    hi ,

    i am using this code to use flash header on my website.
    Movie loads fine in IE , CHrome

    but in FF

    The movie only loads with index.php but when i click on the links on home page (which are joomla articles)

    The movie does not load in them


    PHP Code:
     <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=8,0,0,24" width="900" height='320'>
        <
    param name="movie" value="flash/header2.swf?button=1" />
        <
    param name="quality" value="high" />
         <
    param name="wmode" value="transparent" />
        <
    param name="menu" value="false" />
        <!--[if !
    IE]> <-->
        <
    object data="flash/header2.swf?button=1"
                
    width="900" height="320" type="application/x-shockwave-flash"
         <
    param name="quality" value="high" />
         <
    param name="wmode" value="transparent" />
         <
    param name="menu" value="false" />
         <
    param name="pluginurl" value="http://www.macromedia.com/go/getflashplayer" />
         
    FAIL (the browser should render some flash contentnot this).
        </
    object
    Please de-reputate me
    © 0o0o0o0

    Its better to rule in Hell then to serve in Heaven

  • #2
    Supreme Master coder! _Aerospace_Eng_'s Avatar
    Join Date
    Dec 2004
    Location
    In a place far, far away...
    Posts
    19,291
    Thanks
    2
    Thanked 1,043 Times in 1,019 Posts
    Where is the rest of your code? You appear to be missing some code. It should look something like this
    Code:
    <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000"
       codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,40,0"
       width="300" height="120">
     <param name="movie" value="http://www.macromedia.com/shockwave/download/triggerpages_mmcom/flash.swf">
     <param name="quality" value="high">
     <param name="bgcolor" value="#FFFFFF">
     <!--[if !IE]> <-->
     <object data="http://www.macromedia.com/shockwave/download/triggerpages_mmcom/flash.swf"
             width="300" height="120" type="application/x-shockwave-flash">
      <param name="quality" value="high">
      <param name="bgcolor" value="#FFFFFF">
      <param name="pluginurl" value="http://www.adobe.com/go/getflashplayer">
      FAIL (the browser should render some flash content, not this).
     </object>
     <!--> <![endif]-->
    </object>
    Last edited by _Aerospace_Eng_; 03-10-2009 at 08:27 AM.
    ||||If you are getting paid to do a job, don't ask for help on it!||||

  • #3
    New to the CF scene
    Join Date
    Mar 2009
    Location
    dakbayan sa san carlos
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    i presume u insert in index.php not as header module

    no need to use conditional comment for ie

    Code:
    <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,19,0" width="900" height="320">
      <param name="movie" value="flash/header2.swf" />
      <param name="quality" value="high" />
      <param name="wmode" value="transparent" />
      <embed src="flash/header2.swf" width="900" height="320" quality="high" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" wmode="transparent"></embed>
    </object>
    Last edited by BatBoy; 03-11-2009 at 09:55 AM. Reason: update

  • #4
    Supreme Master coder! _Aerospace_Eng_'s Avatar
    Join Date
    Dec 2004
    Location
    In a place far, far away...
    Posts
    19,291
    Thanks
    2
    Thanked 1,043 Times in 1,019 Posts
    The use of the conditional comment in IE is to allow you to use the standards compliant object tag rather than the embed tag which isn't part of the standard.
    ||||If you are getting paid to do a job, don't ask for help on it!||||


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •