Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 5 of 5
  1. #1
    New to the CF scene
    Join Date
    Nov 2008
    Posts
    6
    Thanks
    1
    Thanked 0 Times in 0 Posts

    IE 6 Messing up my Search Bar!

    My search bar works perfectly in every browser except IE 6!
    Working:


    Broken in IE 6:


    The code relating to this problem:
    Code:
    <style type="text/css">
    <!--
    .searchbox {
    	height: 12px;
    	font-family: Arial, Helvetica, sans-serif;
    	font-size: 11px;
    	color: #3D1B00;
    	border: 1px solid #FFFFFF;
    	width: 90px;
    	position: relative;
    	top: 0px;
    	_top: 1px;
    }
    -->
    </style>
    <!--begin search bar-->
    <img src="images/searchbarleft.gif" width="5" height="16" align="absbottom" style="float:left;"><input style="float:left;" name="full" type="text" class="searchbox" onFocus="this.value=''" value="search..." size="9"><input style="float:left;" name="image" type="image" onMouseOver="javascript:this.src='images/searchbarright_o.gif';" onMouseOut="javascript:this.src='images/searchbarright.gif';" value="Search" src="images/searchbarright.gif" alt="Search" align="absbottom" style="margin-right:1px;">

  • #2
    Regular Coder
    Join Date
    Oct 2008
    Posts
    130
    Thanks
    0
    Thanked 4 Times in 4 Posts
    Your height coinsides with the font-size.

    Delete the height.

    Does that help? I'm not exactly sure what you want. You may need to change other things around the search bar.

  • #3
    New to the CF scene
    Join Date
    Nov 2008
    Posts
    6
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Well i deleted that line and it still works great in all of the other browsers besides IE 6 but it still looks terrible in IE 6. same problem.
    Last edited by toxicity3440; 11-25-2008 at 02:23 AM.

  • #4
    Regular Coder
    Join Date
    Oct 2008
    Posts
    130
    Thanks
    0
    Thanked 4 Times in 4 Posts
    Check your the things surrounding the search bar. It may be a problem there because the search bar alone works fine for me. Experiment with the search bar alone and with other elements. This could help you find your answer.

  • #5
    New to the CF scene
    Join Date
    Nov 2008
    Posts
    6
    Thanks
    1
    Thanked 0 Times in 0 Posts
    well theres the problem.. the _top = 1px; was messing everything up and setting it to = 0px fixed it in all the browsers! WOOT!!


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •