Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Page 1 of 2 12 LastLast
Results 1 to 15 of 22
  1. #1
    New Coder
    Join Date
    Nov 2008
    Posts
    15
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Content slides over header

    Hello!
    I made a page using css and it works well in IE6, Firefox and safari, but in IE7 my content slips over my header with about 30 pixels. I fixed this by adding 30px bottom margin to my header, but in IE7 it didn't work, it stayed at the same place
    Can anyone take a look at my coding please? Something must be wrong with my css...
    thank you, here's the page
    http://www.unionjackstudio.hu/MBT/index.html

  • #2
    New Coder
    Join Date
    Nov 2008
    Posts
    15
    Thanks
    0
    Thanked 0 Times in 0 Posts

    It works!

    It seems to work now...
    Great!
    Solved!

  • #3
    Master Coder Excavator's Avatar
    Join Date
    Dec 2006
    Location
    Alaska
    Posts
    9,675
    Thanks
    22
    Thanked 1,827 Times in 1,811 Posts
    Hello sepunx2,
    Did you fix this? It looks the same on FF and IE7 here.

    [edit]oops, didn't see your post.
    Validate often DURING development - Use it like a splelchecker | Debug during Development |Write it for FireFox, ignore IE
    Use the right DocType | Validate your markup | Validate your CSS | Why validating is good | Why tables are bad

  • #4
    New Coder
    Join Date
    Nov 2008
    Posts
    15
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Not fixed:(

    Hey!
    Thanks for your reply!
    I thought I fixed it, beacuse it works in IE7 and safari now, but I was wrong..
    now it has a huge margin under my header in IE6.
    In fireworks, the layout is ok, but my menu text is gibberish...
    I just can not make this work on all of these browsers
    So..help needed again
    Thank you!

  • #5
    New Coder
    Join Date
    Nov 2008
    Posts
    15
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Bom?

    Hi! I have a byte order mark in my index. I tried to take it out, but i just
    couldn't. Could this be my problem?

    Quote Originally Posted by Excavator View Post
    Hello sepunx2,
    Did you fix this? It looks the same on FF and IE7 here.

    [edit]oops, didn't see your post.

  • #6
    Supreme Master coder! abduraooft's Avatar
    Join Date
    Mar 2007
    Location
    N/A
    Posts
    14,862
    Thanks
    160
    Thanked 2,223 Times in 2,210 Posts
    Quote Originally Posted by sepunx2 View Post
    Hi! I have a byte order mark in my index. I tried to take it out, but i just
    couldn't. Could this be my problem?
    Yes, most probably. Anything before the DOCTYPE will trigger IE in to quirks mode. Why couldn't you remove the BOM? Is your index page is a single file or created with multiple files (by server side linking)?
    The Dream is not what you see in sleep; Dream is the thing which doesn't let you sleep. --(Dr. APJ. Abdul Kalam)

  • #7
    New Coder
    Join Date
    Nov 2008
    Posts
    15
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks for your reply!
    Quote Originally Posted by abduraooft View Post
    Yes, most probably. Anything before the DOCTYPE will trigger IE in to quirks mode. Why couldn't you remove the BOM? Is your index page is a single file or created with multiple files (by server side linking)?
    It is a simple html file, with a linked css file. BOM is new to me. I read about it's removal, they told me 2 options: 1. Change the format of the file in notepad++ to UTF-8 without bom... I tried, but all my text became gibberish 2. Delete EE BB ( something like that) from the beginning of the page... Tried, but couldn't find anything like this.
    So i couldn't remove it. Should i start a new file in text editor and copy paste my codes? I used to edit this file in dreamweaver.... But no more DW

  • #8
    Supreme Master coder! abduraooft's Avatar
    Join Date
    Mar 2007
    Location
    N/A
    Posts
    14,862
    Thanks
    160
    Thanked 2,223 Times in 2,210 Posts
    Just open the simple notepad and copy all the markup into it and save it. (don't forget to take a backup first)
    The Dream is not what you see in sleep; Dream is the thing which doesn't let you sleep. --(Dr. APJ. Abdul Kalam)

  • #9
    New Coder
    Join Date
    Nov 2008
    Posts
    15
    Thanks
    0
    Thanked 0 Times in 0 Posts

    still wrong in IE6

    Hi!
    I could finally remove the byte order mark.
    It works in IE7, Safari, Firefox
    but in IE6 there is a 30px space under my header, over my content.
    A lot of people still use ie6 here, that is why it is important for me to fix this.
    Any other idea? Something may be wrong with my css layout?
    Thank you

  • #10
    Supreme Master coder! abduraooft's Avatar
    Join Date
    Mar 2007
    Location
    N/A
    Posts
    14,862
    Thanks
    160
    Thanked 2,223 Times in 2,210 Posts
    Try to fix the errors in your markup, see http://validator.w3.org/check?uri=ht...Inline&group=0

    btw, what's the purpose of #leftcolumn there?
    The Dream is not what you see in sleep; Dream is the thing which doesn't let you sleep. --(Dr. APJ. Abdul Kalam)

  • #11
    New Coder
    Join Date
    Nov 2008
    Posts
    15
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi...
    left column and right column are only there, because I couldn't make the effect I wanted without them (I wanted the header to be wider than the content..I know, css is new to me)
    I've been trying this validation thing for days now, but it just gets worse..I can't do this.
    For example: The validator said I needed alt for an image. I don't want alt for the image, but I inserted one, than the validator gave me even more errors. Than I tried to fix a few things following the html tidy code it gave me, but I got more errors again. I'm sure my coding is messed up, but it works in all browsers, except in ie6. I just wanted to fix the layout in ie6 too.
    Validator says my code misses an ending somewhere..I checked, but the ending is right there...
    in the end, all my text are formatted to gibberish and I cannot fix it, because my text editor does not offer ansi format for me...
    What should I do?
    I'm trying to learn validating, but it gets worse, I couldn't fix one problem for days now
    is something wrong with my text editor (text wrangler for osx)?
    thanks

  • #12
    New Coder
    Join Date
    Nov 2008
    Posts
    15
    Thanks
    0
    Thanked 0 Times in 0 Posts
    ...now i figured how to change the format to ascii, the text is ok now, but the BOM came back again...I copy my code to another file, but it won't disappear..
    I'm sure all this validation has nothing to do with my problem, because I've tried everything, but nothing got better...
    If it has something to do woth validation, I need someone to explain the solutions for me, because I just can't fix an error
    ok..I could remove my bom in another text editor...
    Last edited by sepunx2; 11-26-2008 at 07:48 PM.

  • #13
    New Coder
    Join Date
    Nov 2008
    Posts
    15
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Is there a place where i can find common errors found by the validator fixed? So i can learn how to remove these errors?

  • #14
    Supreme Master coder! abduraooft's Avatar
    Join Date
    Mar 2007
    Location
    N/A
    Posts
    14,862
    Thanks
    160
    Thanked 2,223 Times in 2,210 Posts
    Most of the errors are due to some invalid characters!
    Quote Originally Posted by http://www.unionjackstudio.hu/MBT/index.html
    Code:
    <div id="header">
    		  
    		       <img src="images/honlap1_02.jpg"  ��/>
    		    		 
    			   
    		 </div>
    What are they?
    The Dream is not what you see in sleep; Dream is the thing which doesn't let you sleep. --(Dr. APJ. Abdul Kalam)

  • #15
    New Coder
    Join Date
    Nov 2008
    Posts
    15
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Aha!!!!
    I cannot see those characters at all!
    Could you please advise me a text editor for mac?

    Thank you


  •  
    Page 1 of 2 12 LastLast

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •