Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 13 of 13
  1. #1
    New to the CF scene
    Join Date
    May 2008
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts

    I need a little help with my first website

    I am making a website. I really don't know anything about doing so.

    I bought a domain from Yahoo small business and they are also my server. I am using a Mac, Photoshop, and Dreamweaver to put them website together.

    I'm building the pages in Photoshop, slicing it in Photoshop, saving it out as an HTML and moving it to Dreamweaver, typing in the linked parts and then uploading it.

    The main problem I am having is that on my Mac the website looks fine, but on a PC it gets all distorted where the slices are. What can I do to stop this from happening? Again I really don't know any technical stuff, so the simplest solution would be great.

    Thanks in advance.

    Here is my website http://www.jgillustration.com

  • #2
    Regular Coder
    Join Date
    Apr 2008
    Location
    Manila, Philippines
    Posts
    263
    Thanks
    3
    Thanked 12 Times in 12 Posts
    just put these after the title tag.. or before your body begins..
    Code:
    <style>
    
    *{margin:0;
        padding:0;
    }
    
    </style>

  • #3
    Regular Coder
    Join Date
    Jun 2007
    Posts
    805
    Thanks
    123
    Thanked 23 Times in 23 Posts
    Quote Originally Posted by jhaycutexp View Post
    just put these after the title tag.. or before your body begins..
    Code:
    <style>
    
    *{margin:0;
        padding:0;
    }
    
    </style>
    You're missing the type. Correct should be:
    Code:
    <style type="text/css">
    
    *{margin:0px;
        padding:0px;
    }
    
    </style>

  • #4
    New to the CF scene
    Join Date
    May 2008
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Ok, I tried and put it in the coding..
    I haven't checked the PC compatibility but what did happen is the image isn't center anymore. It's over to the right side of the window, despite it being center in Dreamweaver.

    How can I fix that? what part of the code is making it go to the left side instead of the center?

    Again I really don't know anything about codes and such.
    Last edited by Geo7877; 05-18-2008 at 06:46 PM.

  • #5
    The Apostate Apostropartheid's Avatar
    Join Date
    Oct 2007
    Posts
    3,215
    Thanks
    16
    Thanked 265 Times in 263 Posts
    If you've not checked compatibility with IE, this is going to be the least of your problems.

    Edit: just saw link, I'll have a look. You will be very well-off to get a copy of Firefox and the Firebug extension running. It's a lifesaver for troubleshooting.


    It's not over the right. It's on the left. (Checked in Safari, IE and Ffx.)
    Last edited by Apostropartheid; 05-18-2008 at 06:49 PM.

  • #6
    New to the CF scene
    Join Date
    May 2008
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by CyanLight View Post
    If you've not checked compatibility with IE, this is going to be the least of your problems.

    Edit: just saw link, I'll have a look. You will be very well-off to get a copy of Firefox and the Firebug extension running. It's a lifesaver for troubleshooting.
    I just re-put the code in, I was messing with it, so it's back up with the code. So you might have to refresh to get the new version.

  • #7
    The Apostate Apostropartheid's Avatar
    Join Date
    Oct 2007
    Posts
    3,215
    Thanks
    16
    Thanked 265 Times in 263 Posts
    After hard refreshes on all browsers except safari, which doesn't like them, I don't see anything on the right. The splash page is still centered.

  • #8
    New to the CF scene
    Join Date
    May 2008
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by CyanLight View Post
    If you've not checked compatibility with IE, this is going to be the least of your problems.

    Edit: just saw link, I'll have a look. You will be very well-off to get a copy of Firefox and the Firebug extension running. It's a lifesaver for troubleshooting.


    It's not over the right. It's on the left. (Checked in Safari, IE and Ffx.)
    You're right, I said left the second time in that post, I don't know why I wrote right the first time. I'm d/ling firefox now.

    I put the code into the second page of the site, the main.html. Did you notice any difference in it distorting near the slices? All the other pages should still distort.

  • #9
    New to the CF scene
    Join Date
    May 2008
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Ok, in using Firefox, it looks like it does on the PC I've checked with. And the main.html with the new code didn't change at all, and still is stuck to the left side of the screen.

    Can you see the distortion I'm talking about? And the way that anything clickable has a blue box around it? What's causing that?

  • #10
    The Apostate Apostropartheid's Avatar
    Join Date
    Oct 2007
    Posts
    3,215
    Thanks
    16
    Thanked 265 Times in 263 Posts
    Take out the * { margin: 0; padding: 0; } and put in a img { border: 0; }. That should fix it.

  • #11
    New to the CF scene
    Join Date
    May 2008
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by CyanLight View Post
    Take out the * { margin: 0; padding: 0; } and put in a img { border: 0; }. That should fix it.
    Wow, it seems to have worked.

    I have no idea what all this code stuff means, but thank you.

  • #12
    Regular Coder
    Join Date
    Jun 2007
    Posts
    805
    Thanks
    123
    Thanked 23 Times in 23 Posts
    Quote Originally Posted by Geo7877 View Post
    Wow, it seems to have worked.

    I have no idea what all this code stuff means, but thank you.
    The a img { border: 0; } tells the browser NOT to put any border around images which are linked.

    The other rule resets margin and padding.

  • #13
    Regular Coder
    Join Date
    Apr 2008
    Location
    Manila, Philippines
    Posts
    263
    Thanks
    3
    Thanked 12 Times in 12 Posts
    Quote Originally Posted by CaptainB View Post
    You're missing the type. Correct should be:
    Code:
    <style type="text/css">
    
    *{margin:0px;
        padding:0px;
    }
    
    </style>
    aw.. i was assuming he knows that.. sorry... my bad...


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •