Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 4 of 4
  1. #1
    Regular Coder
    Join Date
    Oct 2007
    Posts
    148
    Thanks
    4
    Thanked 4 Times in 4 Posts

    Issues with... Everything?

    First off, page is currently located here: Work In Progress (Note, none of the pages the links point to exist yet)

    CSS is included below.

    First problem is IE only. View it in FF, then in IE, I think you'll understand. In case you don't have one or the other, there is supposed to be a background image in the center of the page. That would be
    Code:
    <div class="contentbacker">...</div>
    , in case you were wondering. Said background image does not appear in IE, and I cannot figure out why. (Besides that fact that it's IE, anyways) ;)


    Second problem appears in both FF and IE, and probably all browsers, but I only have IE and FF. Click the link above, then check out the navigation... The navigation that *appears* to be located 125px from the top (which is what the CSS says), but when you hover over it, nothing happens... Now try hovering at the top of the page... WTF? How can this even be possible? Did I screw something up in the CSS, or what?

    CSS:

    Code:
    /* CSS Document */
    /* Needed for proper positioning */
    * {
     padding:0px;
     margin:0px;
    }
    body {
     background-color:#FFFFFF;
    }
    .banner {
     width:600px;
     height:165px;
     position:absolute;
     left:50%;
     top:0px;
     margin-left:-25%;
     z-index:3;
    }
    .topbacker {
     background-image:url(images/TopBacker.jpg);
     background-repeat:repeat-x;
     width:100%;
     height:120px;
     position:absolute;
     top:0px;
     z-index:2;
    }
    .contentbacker {
     background-image:url(images/ContentBacker.jpg);
     width:600px;
     height:100%;
     position:absolute;
     left:50%;
     margin-left:-25%;
     z-index:1;
    }
    #text {
     font-family:Verdana, Arial, Helvetica, sans-serif;
     font-size:14px;
     font-weight:bold;
     color:#FFFFFF;
     position:absolute;
     top:170px;
     left:20px;
     margin-left:-3px;
     margin-right:10px;
    }
    #text a {
     font-family:Verdana, Arial, Helvetica, sans-serif;
     font-size:14px;
     font-weight:bold;
     color:#CCCCCC;
    }
    #text a:hover {
     font-family:Verdana, Arial, Helvetica, sans-serif;
     font-size:14px;
     font-weight:bold;
     color:#666666;
    }
    .footer {
     background-image:url(images/Footer.jpg);
     height:30px;
     width:100%;
     position:absolute;
     top:110%;
     z-index:2;
    }
    #footertext {
     font-family:Geneva, Arial, Helvetica, sans-serif;
     font-size:12px;
     font-weight:bold;
     color:#FFFFFF;
     position:absolute;
     top:7px;
    }
    .nav {
     background-image:url(images/NavBacker.jpg);
     width:140px;
     height:500px;
     position:absolute;
     top:0px;
     left:0px;
     z-index:3;
    }
    .nav a {
     font-family:Geneva, Arial, Helvetica, sans-serif;
     font-size:10px;
     font-weight:bold;
     color:#FFFFFF;
     position:absolute;
     padding-top:125px;
     padding-left:2px;
    }
    .nav a:hover {
     font-family:Geneva, Arial, Helvetica, sans-serif;
     font-size:10px;
     font-weight:bold;
     color:#999999;
     position:absolute;
     padding-top:125px;
     padding-left:2px;
    }

    Aside from that, any comments on the design or code are welcome. :)

    Thanks in advance for any help you can give me.

  • #2
    Senior Coder effpeetee's Avatar
    Join Date
    Feb 2007
    Location
    Clapham Junction - London SW
    Posts
    4,885
    Thanks
    228
    Thanked 204 Times in 203 Posts
    The menu seems OK to me and the results look alike with IE7 and Firefox 2

    Frank
    Last edited by effpeetee; 11-01-2007 at 07:50 PM.
    * Sources (updated: 21.11.2012.
    Using Windows 8 Professional. 64bit with HP Photosmart 5510 printer Very useful site here.

  • #3
    Senior Coder effpeetee's Avatar
    Join Date
    Feb 2007
    Location
    Clapham Junction - London SW
    Posts
    4,885
    Thanks
    228
    Thanked 204 Times in 203 Posts

    Lightbulb

    This is a screen shot from my PC IE7
    Attached Thumbnails Attached Thumbnails Issues with... Everything?-screenhunter_01-nov.-01-17.37.jpg  
    * Sources (updated: 21.11.2012.
    Using Windows 8 Professional. 64bit with HP Photosmart 5510 printer Very useful site here.

  • #4
    Regular Coder
    Join Date
    Oct 2007
    Posts
    148
    Thanks
    4
    Thanked 4 Times in 4 Posts
    ... Ok, I've tried it using FF 2.0.0.8 at home, whatever version of FF they have set up at school (most likely an older version, because they never update), and IE6 (also at school), and the navigation behaves the same way in all three.

    Screenshot

    (By the way, the cursor doesn't show up in that screenshot, but it is currently located a little bit above the "Home" link.) o.0


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •