Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 8 of 8
  1. #1
    New Coder
    Join Date
    Aug 2006
    Posts
    54
    Thanks
    3
    Thanked 0 Times in 0 Posts

    PNG not displaying in any browser

    Hi all..

    I stumbled across a strange problem..
    Here's my CSS:
    Code:
    #line{
    background:url(images/line.png) repeat-x;
    height:14px;
    position:absolute;
    top:100px;
    }
    Now if i remove the position:absolute, the image appears.. If i add it in the style, it disappears. The problem persists in Firefox and IE6, IE7.. Any help will be appreciated..

    Thanks in advance!
    raghu207

  • #2
    Supreme Master coder! _Aerospace_Eng_'s Avatar
    Join Date
    Dec 2004
    Location
    In a place far, far away...
    Posts
    19,291
    Thanks
    2
    Thanked 1,043 Times in 1,019 Posts
    Got link? You may have to add a left or right declaration.
    ||||If you are getting paid to do a job, don't ask for help on it!||||

  • #3
    Regular Coder
    Join Date
    Sep 2007
    Location
    Raleigh, NC
    Posts
    273
    Thanks
    7
    Thanked 59 Times in 52 Posts
    I'm with aero--likely it's either a problem with z-index or the fact that you didn't supply a horizontal offset for it. Browser defaults can act weird in those cases.
    Last edited by vtjustinb; 10-02-2007 at 06:00 PM.

  • #4
    Senior Coder
    Join Date
    Feb 2003
    Posts
    1,665
    Thanks
    0
    Thanked 27 Times in 25 Posts
    width?

  • Users who have thanked Bill Posters for this post:

    raghu207 (10-03-2007)

  • #5
    Supreme Master coder! _Aerospace_Eng_'s Avatar
    Join Date
    Dec 2004
    Location
    In a place far, far away...
    Posts
    19,291
    Thanks
    2
    Thanked 1,043 Times in 1,019 Posts
    Quote Originally Posted by Bill Posters View Post
    width?
    Sometimes you overlook the simple things!
    ||||If you are getting paid to do a job, don't ask for help on it!||||

  • #6
    Regular Coder
    Join Date
    Apr 2006
    Posts
    117
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Yeah, width can throw it off.

    Also, after you figure that out make sure that your positioning is right for where you have the item placed. The z-index and all that can be very touchy.

    EDIT: Oh, and it would also help if we could look at what you are doing :P

  • #7
    New Coder
    Join Date
    Aug 2006
    Posts
    54
    Thanks
    3
    Thanked 0 Times in 0 Posts
    Doh! Yeah, I added width:100% and it worked. Thanks guys

  • #8
    New Coder
    Join Date
    Sep 2007
    Posts
    24
    Thanks
    4
    Thanked 1 Time in 1 Post
    I have spent hours before trying to troubleshoot this exact problem. And almost every time I forget to declare a width.

    I suggest we all put a sticky note on our monitor that says "WIDTH!"


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •