Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 6 of 6
  1. #1
    New to the CF scene
    Join Date
    Jan 2003
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    mozilla and iframes

    im having some trouble getting iframes to display on mozilla but they appear fine on internet explorer. can anyone tell me how to make them compatible with mozilla too? heres a small bit of source, its simple html

    <tr>
    <td colspan="5" height="409">
    <div align="center"><iframe src="start.html" name="theiframe" scrolling=auto width=100% height=100% frameborder=0>Your
    browser does not support iframes.</iframe></div>
    </td>
    </tr>

  • #2
    New to the CF scene
    Join Date
    Jan 2003
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    I got it to work.

    I have mozilla 0.9.9.

    Try this http://www.hyperdark.org/davros/unreal

    If that works [does for me] then all iframes should work.

    Here's my code:

    <iframe src="home.html" name="a" width="100%" height="100%" marginwidth="0" marginheight="0" frameborder="0"></iframe>
    Last edited by Davros; 01-04-2003 at 11:31 AM.

  • #3
    Senior Coder Nightfire's Avatar
    Join Date
    Jun 2002
    Posts
    4,265
    Thanks
    6
    Thanked 48 Times in 48 Posts
    Older versions used ilayers.

  • #4
    New to the CF scene
    Join Date
    Jan 2003
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    meaning i am using i layers?
    I could try it with 1.0.
    I did try it with 1.0
    It still works.
    Last edited by Davros; 01-04-2003 at 11:37 AM.

  • #5
    jkd
    jkd is offline
    Senior Coder jkd's Avatar
    Join Date
    May 2002
    Location
    metro DC
    Posts
    3,163
    Thanks
    1
    Thanked 18 Times in 18 Posts
    Originally posted by Nightfire
    Older versions used ilayers.
    No. Netscape 4 used ilayers, not the Mozilla project. Don't confuse Mozilla with Netscape - NS6 and NS7 are based on Mozilla 0.94 and Mozilla 1.0.1 respectively, but they are not the same.

  • #6
    New to the CF scene
    Join Date
    Jan 2003
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    thanks guys, i figured out what it was. i took out the div part surrounding the iframe script and it worked in mozilla. The iframe is the wrong height in mozilla but at least it works for those browsers now.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •