Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Page 1 of 2 12 LastLast
Results 1 to 15 of 18
  1. #1
    New Coder
    Join Date
    Oct 2002
    Posts
    61
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Links won't work! :'(

    When I click the links on this code it won't take me to the given link, why is that?

    Code:
    <html>
    <head>
    <title>Dotted menu example</title>
    <style type="text/css">
    <!--
    .menu {font-family:Arial; font-weight:bold}
    a.menu {text-decoration:none; color:none; cursor:crosshair;}
    td.menu {border:1px dashed #000000; cursor:crosshair; }
    .sub { filter:glow(color=#ffffff,strength=4)}
    .toplevel {border:5px dashed #000000; background-image:url('http://www.geocities.com/the_emc_site/bg2.jpg'); border-collapse: collapse}
    -->
    </style>
    </head>
    <body>
    <table class="toplevel" width="161" cellpadding="2" cellspacing="3">
     <tr>
      <td class="menu" id="item1">
       <a class="menu" href="http://www.dynamicdrive.com">
        <table class="sub">
         <tr>
          <td>
           <li type="square">Members++</li>
          </td>
         </tr>
        </table>
       </a>
      </td>
     </tr>
     <tr>
      <td class="menu" id="item2">
       <a class="menu" href="http://www.dynamicdrive.com">
        <table class="sub">
         <tr>
          <td>
           <li type="square">Downloads++</li>
          </td>
         </tr>
        </table>
       </a>
      </td>
     </tr>
     <tr>
      <td class="menu" id="item3">
       <a class="menu" href="http://www.dynamicdrive.com">
        <table class="sub">
         <tr>
          <td>
           <li type="square">Get Recruited++</li>
          </td>
         </tr>
        </table>
       </a>
      </td>
     </tr>
    </table>
    </body>
    </html>

  • #2
    Senior Coder
    Join Date
    Jun 2002
    Location
    UK
    Posts
    1,137
    Thanks
    0
    Thanked 0 Times in 0 Posts
    a link should consist of some code like
    <A HREF="http://w3.org">this site</A>
    i don`t see anything like that in your code

    scroots
    Spammers next time you spam me consider the implications:
    (1) that you will be persuaded by me(in a legitimate mannor)
    (2)It is worthless to you, when i have finished

  • #3
    Regular Coder
    Join Date
    Nov 2002
    Location
    Bristol, UK
    Posts
    932
    Thanks
    0
    Thanked 0 Times in 0 Posts
    ...that's odd, scroots, because I can see his links just fine!

    DawgieDog, your code looks fine but to make sure, I copied it into a page and viewed it, and the links worked just fine. I'm not sure why you are experiencing problems?

    ::] krycek [::
    ithium | SOAPI | SDP | PTPScript manual
    "ithium is a non-profit webhost, which is pretty much unique. The mission of ithium is to provide free hosting resources for worthwhile and needy non-profit projects, which otherwise may not be able to obtain such facilities. The money from commercial customers goes to maintain ithium's servers and further development."

  • #4
    Senior Coder
    Join Date
    Jun 2002
    Location
    ColoRockyz
    Posts
    1,649
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Major search engines won't list your page if there's just one broken link.
    Zoobie or not Zoobie...That is the problem.
    <body onUnload="flush( ! )">

  • #5
    Senior Coder
    Join Date
    Jun 2002
    Location
    UK
    Posts
    1,137
    Thanks
    0
    Thanked 0 Times in 0 Posts
    krycek i was just looking at the source code.

    scroots
    Spammers next time you spam me consider the implications:
    (1) that you will be persuaded by me(in a legitimate mannor)
    (2)It is worthless to you, when i have finished

  • #6
    New Coder
    Join Date
    Oct 2002
    Posts
    61
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Originally posted by krycek
    ...that's odd, scroots, because I can see his links just fine!

    DawgieDog, your code looks fine but to make sure, I copied it into a page and viewed it, and the links worked just fine. I'm not sure why you are experiencing problems?

    ::] krycek [::
    Hmm, strange I copy the source I save it as HTMl and I open it in IE and I click on one of the links and it doesn't take me to the given URL.

  • #7
    Regular Coder
    Join Date
    Nov 2002
    Location
    Bristol, UK
    Posts
    932
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Originally posted by scroots
    krycek i was just looking at the source code.

    scroots
    ...scroots, can I ask question?

    WHAT source code???

    I mean, if you are talking about the same source code as me... the code that DawgieDog posted... then you simply didn't see the links.

    He hasn't edited the post, and the code has been there from the start.

    Otherwise, I can only assume that you were looking at some other source code, that was not mentioned here? If so, can you please share it?

    Everyone can make mistakes but I am surprised that once I had mentioned it, you didn;t notice! The links are in the code, and they work fine for me.

    Just in case you missed it though, here's an extract:

    Originally posted by DawgieDog
    Code:
       <a class="menu" href="http://www.dynamicdrive.com">
        <table class="sub">
         <tr>
          <td>
           <li type="square">Downloads++</li>
          </td>
         </tr>
        </table>
       </a>
    All appears to be present and correct!

    ::] krycek [::
    Last edited by krycek; 12-22-2002 at 10:22 PM.
    ithium | SOAPI | SDP | PTPScript manual
    "ithium is a non-profit webhost, which is pretty much unique. The mission of ithium is to provide free hosting resources for worthwhile and needy non-profit projects, which otherwise may not be able to obtain such facilities. The money from commercial customers goes to maintain ithium's servers and further development."

  • #8
    Regular Coder
    Join Date
    Nov 2002
    Location
    Bristol, UK
    Posts
    932
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Originally posted by DawgieDog
    Hmm, strange I copy the source I save it as HTMl and I open it in IE and I click on one of the links and it doesn't take me to the given URL.
    Hmmmm... well, when I read that I opened the file in IE and sure enough, it doesn't work. It works just fine in Mozilla, however!

    Not sure why.

    ::] krycek [::
    ithium | SOAPI | SDP | PTPScript manual
    "ithium is a non-profit webhost, which is pretty much unique. The mission of ithium is to provide free hosting resources for worthwhile and needy non-profit projects, which otherwise may not be able to obtain such facilities. The money from commercial customers goes to maintain ithium's servers and further development."

  • #9
    New Coder
    Join Date
    Oct 2002
    Posts
    61
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Originally posted by krycek
    Hmmmm... well, when I read that I opened the file in IE and sure enough, it doesn't work. It works just fine in Mozilla, however!

    Not sure why.

    ::] krycek [::
    \

    Aww crap, don't tell me it doesn't work in IE. I like that menu .

  • #10
    Regular Coder
    Join Date
    Jun 2002
    Posts
    166
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Not sure why.
    <table> element NOT allowed in <a>...</a>

  • #11
    New Coder
    Join Date
    Oct 2002
    Posts
    61
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Originally posted by PauletteB
    <table> element NOT allowed in <a>...</a>
    So what's the solution? Sorry, I'm a newb at this.

  • #12
    Regular Coder
    Join Date
    Jun 2002
    Posts
    166
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Put the link inside the table. You may want to retouch the css.

    <tr>
    <td class="menu" id="item1">
    <table class="sub">
    <tr>
    <td>
    <li type="square"><a class="menu" href="http://www.dynamicdrive.com">Members++</a></li>
    </td>
    </tr>
    </table>
    </td>
    </tr>

  • #13
    Regular Coder
    Join Date
    Nov 2002
    Location
    Bristol, UK
    Posts
    932
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Originally posted by PauletteB
    <table> element NOT allowed in <a>...</a>
    hmmm, I never knew that!

    ...not that I have ever, to the best of my knowledge, felt like doing it...

    however, why is it not allowed? Is that according to the W3C spec?

    ::] krycek [::
    ithium | SOAPI | SDP | PTPScript manual
    "ithium is a non-profit webhost, which is pretty much unique. The mission of ithium is to provide free hosting resources for worthwhile and needy non-profit projects, which otherwise may not be able to obtain such facilities. The money from commercial customers goes to maintain ithium's servers and further development."

  • #14
    Regular Coder
    Join Date
    Jun 2002
    Location
    Ontario, Canada
    Posts
    183
    Thanks
    0
    Thanked 0 Times in 0 Posts
    If it works in Moz and not IE, then it's likely because IE is way behind in standard-compliancy...

    Should be fine as both are block elements... Try "display: block" in the table CSS...

    Weirdness...
    Offtone.com - In the works...

  • #15
    New Coder
    Join Date
    Oct 2002
    Posts
    61
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Originally posted by PauletteB
    Put the link inside the table. You may want to retouch the css.

    <tr>
    <td class="menu" id="item1">
    <table class="sub">
    <tr>
    <td>
    <li type="square"><a class="menu" href="http://www.dynamicdrive.com">Members++</a></li>
    </td>
    </tr>
    </table>
    </td>
    </tr>
    That messes up my CSS and I can't get it to work. Why can't I make the borders of this menu dashed?
    Code:
    <style>
    A:link {text-decoration:none; cursor:crosshair;}
    A:visited {text-decoration:none; cursor:crosshair;}
    
    a.Menlink {
    width;100 /*Make this the max width you would like*/
    }
    .MenuTable{
    border-style:outset;
    border-width:3;
    border-color:red;
    }
    .MenuTd{
    Border-top-style:solid;
    border-top-width:1;
    border-top-color:darkred;
    }
    </style>
    <table bgcolor="#000000" class="MenuTable" border="0" cellpadding="1" cellspacing="2">
    <tr>
         <td><img src="bullet" /></td><td><a href="#" class="Menlink">Menu Link</a></td>
    </tr>
    <tr>
         <td class="MenuTd"><img src="bullet" /></td><td class="MenuTd"><a href="#" class="Menlink">Menu Link</a></td>
    </tr>
    <tr>
         <td class="MenuTd"><img src="bullet" /></td><td class="MenuTd"><a href="#" class="Menlink">Menu Link</a></td>
    </tr>
    <tr>
         <td class="MenuTd"><img src="bullet" /></td><td class="MenuTd"><a href="#" class="Menlink">Menu Link</a></td>
    </tr>
    <tr>
         <td class="MenuTd"><img src="bullet" /></td><td class="MenuTd"><a href="#" class="Menlink">Menu Link</a></td>
    </tr>
    </table>


  •  
    Page 1 of 2 12 LastLast

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •