Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 6 of 6
  1. #1
    Regular Coder
    Join Date
    May 2006
    Location
    Bristol, UK
    Posts
    147
    Thanks
    6
    Thanked 2 Times in 2 Posts

    Niggly Little problems with IE and FF...

    Hi Guys,

    Sorry to pester you all with another one of these common niggly little problems, ive been around for a while and learnt a hell of a lot from you guys, but this is one that is bugging me!!

    I have starting this site... www.jdbcomputers.co.uk

    However in IE the list of services on the left is all out of line and in FF there are some annoying spaces at the very top

    Does anyone have any ideas of how to get round this?

    Thanks

    Jon
    "You only live once, play it right, and once is enough" - me :)
    "When i die only god can take my soul" - me again! :P

  • #2
    Regular Coder
    Join Date
    May 2006
    Posts
    290
    Thanks
    6
    Thanked 14 Times in 14 Posts
    try to validate your code first.

    Click HERE

    Definently fix some of your attribute issues or possibly your doctype to comply with the attributes you are trying to use.

    -trigger
    Last edited by trigger_tre; 12-16-2006 at 02:13 PM.

  • #3
    Regular Coder
    Join Date
    May 2006
    Location
    Bristol, UK
    Posts
    147
    Thanks
    6
    Thanked 2 Times in 2 Posts
    Hi mate,

    thanks for your help there,

    i have got the errors down frm 19 to 6!! but the 6 that are there make no sence to me, they are going on about incorrect doc type for those attributes, however i have tried various different doc types to no avail...

    Fixing the 13 errors however dident fix any of my niggly little problems

    Any other ideas?

    Thanks

    Jon
    "You only live once, play it right, and once is enough" - me :)
    "When i die only god can take my soul" - me again! :P

  • #4
    Regular Coder
    Join Date
    May 2006
    Posts
    290
    Thanks
    6
    Thanked 14 Times in 14 Posts
    add this just below the <head>

    Code:
    <meta http-equiv="Content-Type" content="text/html;charset=utf-8" >
    refresh the page then try to re-validate it.

    I see more errors but we will take it one step at a time.

    -trigger

  • #5
    Senior Coder Arbitrator's Avatar
    Join Date
    Mar 2006
    Location
    Splendora, Texas, United States of America
    Posts
    3,371
    Thanks
    32
    Thanked 286 Times in 280 Posts
    Quote Originally Posted by jonnybinthemix View Post
    i have got the errors down frm 19 to 6!! but the 6 that are there make no sence to me, they are going on about incorrect doc type for those attributes, however i have tried various different doc types to no avail...
    Those attributes are deprecated in favor of CSS. Replace them with their CSS equivalents of the background-image, width, height, border-width, and margin/padding properties. You could clean up a lot more of the attributes using CSS as well.

    Concerning your layout, if you’re going to use tables for layout, at least use only one table… I don’t think I’ve ever seen so many nested tables. I’d say that it’s rare that there should be a justification for nesting multiple tables.
    Last edited by Arbitrator; 12-16-2006 at 05:22 PM.
    For every complex problem, there is an answer that is clear, simple, and wrong.

  • #6
    Regular Coder
    Join Date
    May 2006
    Location
    Bristol, UK
    Posts
    147
    Thanks
    6
    Thanked 2 Times in 2 Posts
    Hi Guys,

    Thanks for all your help

    Ive been working on it all day, and i really thought i was getting somewhere, and when i previewed in a browser, it was all over the place.

    My original plan this morning was to take the top (pic + menu etc) and turn it all into css with no tables, thinking this would sort the gaps at the top in FF out. just when i thought i was getting somewhere after hours and hours it dident work so i got mad and closed it all without saving it!

    So now im running out of steam!! ive tried everything to solve the 6 remaining errors, but no joy.

    I used to be pretty good at all this, but where i havent done it for so long ive forgotten everything!

    Someone please help...! :'(

    Thanks

    Jon
    "You only live once, play it right, and once is enough" - me :)
    "When i die only god can take my soul" - me again! :P


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •