Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 3 of 3
  1. #1
    New to the CF scene
    Join Date
    Dec 2006
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts

    blank image link css rollover

    I have been banging my head aginst my desk for two days trying to figure out what I am doing wrong here. I've done this several times before, and it has always worked. For some reason, it's not showing up in forefox, but works fine in IE. (weird, I know)

    .home a:link, .home a:visited, .home a:active, { background-image: url(http://www.brandsmithapparel.com/cp/images/home.gif); width: 174px; height: 73px; display: block; }

    .home a:hover { background-position: 0 -73px; }

    <td class="home" height="73" valign="middle"><a href="http://www.cafepress.com/brandsmith"><img src="http://www.brandsmithapparel.com/cp/images/homeblank.gif" height="73" width="174" border="0"></a></td>


    For complete code, see http://www.brandsmithapparel.com/cp/blank.html Try looking at it in both browsers to see what I mean.

    Thanx much

  • #2
    Senior Coder Arbitrator's Avatar
    Join Date
    Mar 2006
    Location
    Splendora, Texas, United States of America
    Posts
    3,387
    Thanks
    32
    Thanked 288 Times in 282 Posts
    It looks messed up in Firefox 2, of course. I can’t say that it looks right in Internet Explorer 7 either though. In addition to the right column being out of alignment, I had to load it over and over in Internet Explorer to get the images to show up and the main background image still won’t show.

    Edit: Looks like the main background image not showing up issue that I was experiencing was due to me being on dial‐up and that image being nearly a megabyte in file size.

    As for a solution, I suppose it might help if both your XHTML and CSS were valid…
    Last edited by Arbitrator; 12-11-2006 at 02:13 PM.
    For every complex problem, there is an answer that is clear, simple, and wrong.

  • #3
    New to the CF scene
    Join Date
    Dec 2006
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts

    sorry about that-

    I think I gave you the wrong link- The columns didn't line up because there was no content in the main area. I would so appreciate it if you would look again at http://www.cafepress.com/brandsmith.

    Thanks for the feedback about the background image though - I'll work on that.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •