Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 6 of 6
  1. #1
    Regular Coder
    Join Date
    Apr 2005
    Posts
    114
    Thanks
    14
    Thanked 0 Times in 0 Posts

    simple loadMovie prob. Paths revert to parent file structure.

    I'm trying to loadMovie("someFolder/test.swf", "container");

    /wholeSiteFolder/
    _____movie.swf
    _____index.html
    _____/someFolder/
    __________test.swf
    __________file1.xml
    __________file2.xml

    The problem is that the test.swf requires two .xml files that are located in the same folder "someFolder". But when trying to run the movie it is looking for the .xml files in the parent folder of someFolder.

    I can run test.swf on its own it works on it's own and the paths are correct but when i try it with loadMovie it can't find the .xml files because it's looking at the root. Probably an easy fix, or else it can't be fixed. Any ideas?

    Thanks!
    Last edited by jpolo9; 07-16-2006 at 11:12 PM.

  • #2
    Supreme Master coder! _Aerospace_Eng_'s Avatar
    Join Date
    Dec 2004
    Location
    In a place far, far away...
    Posts
    19,291
    Thanks
    2
    Thanked 1,043 Times in 1,019 Posts
    Use a leading forward slash in front of the file so it starts at the root of the site.
    Code:
    loadMovie("/someFolder/test.swf", "container");
    Same goes for when you call your xml files from test.swf.
    ||||If you are getting paid to do a job, don't ask for help on it!||||

  • #3
    Regular Coder
    Join Date
    Apr 2005
    Posts
    114
    Thanks
    14
    Thanked 0 Times in 0 Posts
    well all the paths are right. The problem is that when I load the test.swf into the main movie.swf the paths that were in test.swf default to the root folder instead of the folder that they are actually in.

    so it puts the xml at wholeSiteFolder/file1.xml instead of wholeSiteFolder/someFolder/file1.xml.

    What is worse is that test.swf is actually the FIG image gallery so I can't edit its code and I can't even purchase it. And I need it to load in the flash file because when i tried to have multiple image galleries open as popups it kills IE. I started another thread about the Ie problem but got no responses
    Last edited by jpolo9; 07-16-2006 at 11:13 PM.

  • #4
    Supreme Master coder! _Aerospace_Eng_'s Avatar
    Join Date
    Dec 2004
    Location
    In a place far, far away...
    Posts
    19,291
    Thanks
    2
    Thanked 1,043 Times in 1,019 Posts
    So you can't edit the calls to the xml files then? Then why not just move the xml files to the root?
    ||||If you are getting paid to do a job, don't ask for help on it!||||

  • #5
    Regular Coder
    Join Date
    Apr 2005
    Posts
    114
    Thanks
    14
    Thanked 0 Times in 0 Posts
    ahh would that I could. But since i need multiple image galleries, I also need multiple xml files. So i can't move it to the root because then I would only be able to use one xml file and thus have only one gallery.

    The xml file is really just menu.xml to control which pictures load. But since I can't edit the swf for the image gallery, i can't set it to use multiple menu.xml's for each different gallery.

    So the only thing I could think to do was put a diffent gallery.swf into different folders and load them into flash separately so that they would call the menu.xml that is in their folder. Only for some reason it is looking for menu.xml in the root folder. :S
    Last edited by jpolo9; 07-16-2006 at 10:38 PM.

  • #6
    New to the CF scene
    Join Date
    Jul 2006
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    if you want, you can try using a swf decompiler, such as the one on the sothink website. I would put the link, but it gets all starred out. There are free ones, this one is just the best. It will decompile the swf file basically give you the .fla file to do with whatever you want-
    Last edited by pnels; 07-17-2006 at 03:04 PM.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •