Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 3 of 3
  1. #1
    New Coder
    Join Date
    Apr 2007
    Posts
    37
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Embedding a Windows Media Encoder Stream

    On this page:

    http://whitecapgraphics.com/bates/round2/webcam.php

    I have embedded a webcam streamed from Windows Media Encoder, using some instructions I googled. Unfortunately, the stream is embedded using this code:

    Code:
    <!--- BEGIN PLAYER --->
    <!-- webbot bot="HTMLMarkup" startspan ---->
    <object ID="MediaPlayer" WIDTH="320" HEIGHT="240" CLASSID="CLSID:22D6f312-B0F6-11D0-94AB-0080C74C7E95" STANDBY="Loading Windows 
    
    Media Player components..." TYPE="application/x-oleobject" 
    
    CODEBASE="http://activex.microsoft.com/activex/controls/mplayer/en/nsmp2inf.cab#Version=6,4,7,1112">
    
    <param name="autoStart" value="True">
    <param name="filename" value="http://68.148.4.208:3299">
    <param NAME="ShowControls" VALUE="False">
    <param NAME="ShowStatusBar" VALUE="False">
    <embed TYPE="application/x-mplayer2" SRC="http://68.148.4.208:3299" NAME="MediaPlayer" WIDTH="320" HEIGHT="240" autostart="1" 
    
    showcontrols="0"></embed></object>
    <!-- webbot bot="HTMLMarkup" endspan ---->
    <!--- end PLAYER --->
    The document has a transitional doctype, which is stopping the stream from playing in Firefox. I'm guessing this is because the deprecation of the object/embed tag (I can't remember which of these tags, or both, is deprecated.) When I remove the doctype declaration it streams fine.

    My question is, how do I embed this stream to make it happy with the transitional doctype, and still play in most browsers?

    PS - Please ignore the fact that the stream is sitting oddly in that blue box, or any funny faces I may be making on the cam.
    PSS - Hopefully the stream is even working properly!
    PSSS - Give the stream a minute to load.
    Last edited by sarahbee; 05-01-2007 at 09:26 PM.

  • #2
    New Coder
    Join Date
    Apr 2007
    Posts
    37
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I'm currently browsing through the sticky related to this topic. Hopefully I can find the answer there.

  • #3
    New Coder
    Join Date
    Apr 2007
    Posts
    37
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Well, I went with an iframe to embed the unhappy non standards code. I'm sure there must be a better way to do it, so I'd welcome those thoughts. Until then, it's working, so I'm temporarily sated.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •