Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 5 of 5
  1. #1
    New Coder
    Join Date
    Oct 2012
    Posts
    44
    Thanks
    7
    Thanked 3 Times in 3 Posts

    File not being found on site - don't know why

    When i check the error log for the site I'm doing, it's filled with references to a .eot font file. The file named in the log is definitely there, with the correct name, in the correct place. The referring link is always the css file.
    The font family declaration in the css is:
    Code:
    @font-face {
        font-family: 'BenthamRegular';
        src: url('bentham-webfont.eot');
      src: url('bentham-webfont.eot?#iefix') formstyleat('embedded-opentype'),
             url('bentham-webfont.woff') formstyleat('woff'),
             url('bentham-webfont.ttf') formstyleat('truetype'),
             url('bentham-webfont.svg#benthamRegular') formstyleat('svg');
        font-weight: normal;
        font-style: normal;
    }
    i'm using another font, in an identical manner, with no problem. what can be causing the error?

  • #2
    The fat guy next door VIPStephan's Avatar
    Join Date
    Jan 2006
    Location
    Halle (Saale), Germany
    Posts
    8,876
    Thanks
    6
    Thanked 1,035 Times in 1,008 Posts
    Could be an error in the font file itself. Are you able to access the font directly by typing the path into the address bar?
    Can you give us a link to a live example?

  • #3
    New Coder
    Join Date
    Oct 2012
    Posts
    44
    Thanks
    7
    Thanked 3 Times in 3 Posts
    yes I checked and I can access the file.
    Last edited by backa; 11-09-2012 at 01:26 PM.

  • #4
    The fat guy next door VIPStephan's Avatar
    Join Date
    Jan 2006
    Location
    Halle (Saale), Germany
    Posts
    8,876
    Thanks
    6
    Thanked 1,035 Times in 1,008 Posts
    Do you know what I just noticed?
    Code:
    @font-face {
        font-family: 'BenthamRegular';
        src: url('bentham-webfont.eot');
      src: url('bentham-webfont.eot?#iefix') formstyleat('embedded-opentype'),
             url('bentham-webfont.woff') formstyleat('woff'),
             url('bentham-webfont.ttf') formstyleat('truetype'),
             url('bentham-webfont.svg#benthamRegular') formstyleat('svg');
        font-weight: normal;
        font-style: normal;
    }
    That’s crap, it must read “format”. And it is exactly this why the font isn’t used.

  • Users who have thanked VIPStephan for this post:

    backa (11-08-2012)

  • #5
    New Coder
    Join Date
    Oct 2012
    Posts
    44
    Thanks
    7
    Thanked 3 Times in 3 Posts
    Well Spotted! Thank you!

    what is strange is that only the one file gave an error (i'm using 2 custom fonts, the other one had the error too). i feel quite foolish!

    thanks again.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •