Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 5 of 5
  1. #1
    New to the CF scene
    Join Date
    Aug 2009
    Posts
    8
    Thanks
    3
    Thanked 0 Times in 0 Posts

    Question links working in Firefox bt not in IE

    hi _
    not used this site before

    building five page website and can see it working page to page in Firefox
    but in Internet Explorer 6 (can't upgrade : /) the pages don't change
    even though the link field at the bottom of the screen is indicating the correct page when i hover over the link!!

    the links are all buttons i built in photoshop
    and run on javascript to glow when user hovers then light up when clicked

    example of link code
    Code:
    <a href       = "index.htm"
            onMouseOver = "imgOn('img1')"
            onMouseOut  = "imgOff('img1')"
            onMouseDown = "imgClick('img1')">
            <img name   = "img1"
              border    = 0
              height    = 31
              width     = 150
              src       = "homeMouseOff.jpg" />
          </a>
    any suggestions be gratefully received _ thanks

  • #2
    Senior Coder ckeyrouz's Avatar
    Join Date
    Jun 2009
    Location
    Montreal, Canada
    Posts
    1,044
    Thanks
    5
    Thanked 179 Times in 179 Posts
    try this:
    Code:
    <a href       = "index.htm"
           >
            <img name   = "img1"
              border    = 0
              height    = 31
              width     = 150
     onMouseOver = "imgOn('img1')"
            onMouseOut  = "imgOff('img1')"
            onMouseDown = "imgClick('img1')"
              src       = "homeMouseOff.jpg" />
          </a>
    move the events from the anchor to the image itself.

  • Users who have thanked ckeyrouz for this post:

    ifc_programmer (08-16-2009)

  • #3
    Supreme Master coder! _Aerospace_Eng_'s Avatar
    Join Date
    Dec 2004
    Location
    In a place far, far away...
    Posts
    19,291
    Thanks
    2
    Thanked 1,043 Times in 1,019 Posts
    Try this
    Code:
    <a href= "index.htm" onmouseover="imgOn('img1')" onmouseout="imgOff('img1')" onclick="imgClick('img1')"><img name="img1" border="0" height="31" width="150" src="homeMouseOff.jpg" /></a>
    ||||If you are getting paid to do a job, don't ask for help on it!||||

  • #4
    New to the CF scene
    Join Date
    Aug 2009
    Posts
    8
    Thanks
    3
    Thanked 0 Times in 0 Posts
    hi ckeyrouz
    re: my query about links not working in IE6
    have done as you suggested
    but no joy : /
    tried to go through the code to see if i've missed something
    as didn't want to bug you again (sorry about this)
    am i missing something here?

    <a href = "index.htm">
    <img name = "img1"
    border = 0
    height = 31
    width = 150
    onMouseOver = "imgOn('img1')"
    onMouseOut = "imgOff('img1')"
    onMouseDown = "imgClick('img1')"
    src = "homeMouseOff.jpg" />
    </a>
    _____________________
    update...

    okay _ four out of five pages are working in IE6
    it's the index page causing the head ache
    so will trawl through and find the problem (i hope : / )
    many thanks for your help

    take care ; )
    Last edited by ifc_programmer; 08-16-2009 at 08:33 PM. Reason: update

  • #5
    Supreme Master coder! _Aerospace_Eng_'s Avatar
    Join Date
    Dec 2004
    Location
    In a place far, far away...
    Posts
    19,291
    Thanks
    2
    Thanked 1,043 Times in 1,019 Posts
    Yeah try my solution.
    ||||If you are getting paid to do a job, don't ask for help on it!||||


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •