Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 1 of 1
  1. #1
    New Coder
    Join Date
    Jan 2005
    Posts
    74
    Thanks
    0
    Thanked 1 Time in 1 Post

    Question Issues publishing a WebProject Error:500.19 [IIS7 / VS2008 ASP.NET]

    I've got a newby question, I've made a few web applications (for school) but never actually had to host it to the outside world (I think the term is - publish), meaning I now have a web application and I need to allow other users (non-local on my systems) to access the webpage - pretty typical requirement I am sure.

    This is what I have done so far...

    - Created a webpage using VS2005 (ASP.NET 2.0) on some folder on my F:\ drive
    - Converted the project to VS2008 (ASP.NET 3.5) and continued development
    - Tested it and it runs perfectly fine (using LocalHost)
    - Moved the Project Folder to C:\inetput\wwwroot\Project
    - Installed (enabled) IIS7 (Vista Ultimate 64bit)
    - Created a new "Web Site" in IIS7 and chose my Project

    Note - now my IIS (Sites) shows 2 web sites - "default web site" (which has the folder structure of "Project" within it as it is located in wwwroot) and "Project" which is the web site I "created" manually (not sure if this is ok but...)


    Now, when I open internet explorer and do "http://192.168.1.100/default.aspx" on my local computer (for testing - if it doesn't work locally it won't work over the net) I get the following error:
    HTTP Error 500.19 - Internal Server Error
    The requested page cannot be accessed because the related configuration data for the page is invalid.

    Module IIS Web Core
    Notification BeginRequest
    Handler Not yet determined
    Error Code 0x80070021
    Config Error This configuration section cannot be used at this path. This happens when the section is locked at a parent level. Locking is either by default (overrideModeDefault="Deny"), or set explicitly by a location tag with overrideMode="Deny" or the legacy allowOverride="false".
    Config File \\?\C:\inetpub\wwwroot\Project\web.config


    On a positive note, it seems to be trying to access wwwroot\Project\default.aspx - but of course something is going wrong somewhere.

    Realistically I have no clue what could be the problem - probably something very basic but I've never actually done any of this before.

    Any help would be greatly appreciated.
    Thanks,
    Last edited by Shaitan00; 11-25-2008 at 06:43 AM.


 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •