The last few days I have been installing and fiddling around with SSL. I created a sub-domain ( within normal cPanel. I then created a folder called "commission", had files, images etc along with the .htaccess changing the http to https on entering that folder.

Though, the problem I had was I just wanted the sub-domain by itself, if you go back to you will still have the https protocol and all that information would be unencrypted even though it wouldn't matter a normal persons perception who knows very little about the web, would think this is bad etc.

So I created a whole new account in WHM, which was though instead of the sub-domain it was a pure account. Now I uploaded all files and images to that account, installed the SSL Cert and everything worked perfect except for one thing. When I went to the root of the domain it would go back to - now I believe this is caused by the DNS I am very unsure of what to do at this point in time, I come to you guys!

So I want to be able to go to WITH the https protocol and be able just to see the root, not The normal http protocol works fine. I have also tried reinstalling and re-installing the SSL Certificate.