Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 6 of 6
  1. #1
    Senior Coder JamieR's Avatar
    Join Date
    Oct 2004
    Location
    United Kingdom
    Posts
    3,161
    Thanks
    0
    Thanked 5 Times in 5 Posts

    Question Flash won't play in Firefox

    hi i created a flash banner in flash mx 2004 professional and uploaded it to my web server to test - it works fine in IE, but it won't play at all in firefox. Firefox will not even acknowledge the html code stating that the flash banner is there it just ignores it. Any ideas how I can get my flash banner to play in Firefox?

    The parameter code I used is:
    <object>
    <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000"
    codebase="http://active.macromedia.com/flash4/cabs/swflash.cab#version=4,0,0,0"
    id="bannnner" width="760" height="150" />
    <param name="movie" value="banner.swf" />
    <param name="quality" value="High" />
    <param name="bgcolor" value="#000000" />
    <param name="_cx" value="20108" />
    <param name="_cy" value="3969" />
    <param name="Src" value="banner.swf" />
    <param name="WMode" value="Window" />
    <param name="Play" value="1" />
    <param name="Loop" value="-1" />
    <param name="Menu" value="-1" />
    <param name="Base" value="" />
    <param name="AllowScriptAccess" value="always" />
    <param name="Scale" value="NoScale" />
    <param name="DeviceFont" value="0" />
    <param name="EmbedMovie" value="0" />
    <param name="SeamlessTabbing" value="1" />
    </object>

    Any ideas anyone??
    -weazel
    Last edited by JamieR; 10-13-2004 at 01:43 PM.

  • #2
    Senior Coder JamieR's Avatar
    Join Date
    Oct 2004
    Location
    United Kingdom
    Posts
    3,161
    Thanks
    0
    Thanked 5 Times in 5 Posts
    any ideas?
    Last edited by JamieR; 10-13-2004 at 01:43 PM.

  • #3
    Senior Coder
    Join Date
    Jul 2004
    Location
    New Zealand
    Posts
    1,315
    Thanks
    0
    Thanked 2 Times in 2 Posts
    Code:
    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
    <html>
    	<head>
    		<title>Macromedia Flash</title>
    	</head>
    	<body>
    		<object type="application/x-shockwave-flash" data="banner.swf" height="150" width="760"></object>
    	</body>
    </html>

  • #4
    Senior Coder JamieR's Avatar
    Join Date
    Oct 2004
    Location
    United Kingdom
    Posts
    3,161
    Thanks
    0
    Thanked 5 Times in 5 Posts
    thanks for the help but now it won't play in firefox or IE, the status bar at the bottom just moves across slowly.
    I've put in a load of relevant parameters, but to no avail.

  • #5
    Senior Coder
    Join Date
    Jul 2004
    Location
    New Zealand
    Posts
    1,315
    Thanks
    0
    Thanked 2 Times in 2 Posts
    Well, it works fine in my Firefox. Internet Explorer needs the following code:
    Code:
    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
    <html>
    	<head>
    		<title>Macromedia Flash</title>
    	</head>
    	<body>
    		<object type="application/x-shockwave-flash" data="test.swf" height="90" width="675">
    			<param name="movie" value="test.swf">
    		</object>
    	</body>
    </html>
    If you can't get it working, you have to show me how you've used it.

  • #6
    Senior Coder JamieR's Avatar
    Join Date
    Oct 2004
    Location
    United Kingdom
    Posts
    3,161
    Thanks
    0
    Thanked 5 Times in 5 Posts
    ok thanks its working now
    cheers for the help


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •