Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 3 of 3
  1. #1
    Senior Coder nikos101's Avatar
    Join Date
    Dec 2006
    Location
    London
    Posts
    1,007
    Thanks
    59
    Thanked 10 Times in 10 Posts

    However it is embedded in a page the images do not appear

    I have a flash movie here that takes its images from URLS like so

    Code:
    package  {
        
        import flash.display.DisplayObject;
        import org.papervision3d.materials.BitmapFileMaterial;
        import org.papervision3d.materials.utils.MaterialsList;
        import org.papervision3d.events.InteractiveScene3DEvent;
        import org.papervision3d.objects.primitives.Cube;
        [SWF(width="200", height="150", backgroundColor="0xB1CEDF", frameRate="31")] 
        public class MC_Cube extends PaperBase {
           private var frontMaterial:BitmapFileMaterial = new BitmapFileMaterial("../../images2/logotrans.png");
           private var backMaterial:BitmapFileMaterial = new BitmapFileMaterial("http://missionofcompassion.org/beta_web/images2/logo%20edges%20trans.png");
           private var leftMaterial:BitmapFileMaterial = new BitmapFileMaterial("http://missionofcompassion.org/beta_web/images2/logo%20edges%20trans.png");
           private var rightMaterial:BitmapFileMaterial = new BitmapFileMaterial("http://missionofcompassion.org/beta_web/images2/logo%20edges%20trans.png");
           private var topMaterial:BitmapFileMaterial = new BitmapFileMaterial("http://missionofcompassion.org/beta_web/images2/logo%20edges%20trans.png");
           private var bottomMaterial:BitmapFileMaterial = new BitmapFileMaterial("http://missionofcompassion.org/beta_web/images2/logo%20edges%20trans.png");
    However when it is embedded in a page the images do not appear, the cube is black. It doesn't matter whether I use dreamweaver to embed it or swfobject2


  • #2
    Supreme Master coder! abduraooft's Avatar
    Join Date
    Mar 2007
    Location
    N/A
    Posts
    14,862
    Thanks
    160
    Thanked 2,223 Times in 2,210 Posts
    The problem might be with the path of the image files. Have a try by removing(replace with _ ) the spaces in the files and call the files using the absolute path, Say /beta_web/images2/logotrans.png, /beta_web/images2/logo_20_edges_trans.png etc
    The Dream is not what you see in sleep; Dream is the thing which doesn't let you sleep. --(Dr. APJ. Abdul Kalam)

  • #3
    Senior Coder nikos101's Avatar
    Join Date
    Dec 2006
    Location
    London
    Posts
    1,007
    Thanks
    59
    Thanked 10 Times in 10 Posts
    Yes that was the problem! Thanks



  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •