Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 3 of 3
  1. #1
    New to the CF scene
    Join Date
    Sep 2013
    Posts
    3
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Generated Map Links not Working

    Hi,

    I'm trying to have a generated google map link to a website. You can find the generated page here:

    http://nutsacbags.com/index.php?main_page=page&id=6

    The part of the code I've been hacking looks like this:


    html += "<br/>" + entry["gsx$"+param_descriptionColumn].$t;
    html += "<br/>" + entry["gsx$"+param_descriptionCityzip].$t;
    html += "<br/><a href=&quot;http://" + entry["gsx$"+param_descriptionWebsite].$t + "&quot;>" + entry["gsx$"+param_descriptionWebsite].$t + "</a>";

    The problem has been with the last line since I need to escape the quote, but \" doesn't work. I ended up using &quot;. The escape character works, but the generated href looks like this:

    http://nutsacbags.com/"http://tahoemountainsports.com" (which clearly doesn't work)

    If you click on one of the markers you'll see the problem.

    Any ideas?

    thanks!
    ~greg

  • #2
    Regular Coder hdewantara's Avatar
    Join Date
    Aug 2009
    Location
    Jakarta, Indonesia.
    Posts
    366
    Thanks
    9
    Thanked 53 Times in 52 Posts
    Untested. Will this help?
    Code:
    html += 
      '<br/><a href="http://' +
      entry['gsx$'+param_descriptionWebsite].$t +
      '">' +
      entry['gsx$'+param_descriptionWebsite].$t + 
      '</a>';

  • Users who have thanked hdewantara for this post:

    gregkise (09-11-2013)

  • #3
    New to the CF scene
    Join Date
    Sep 2013
    Posts
    3
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Worked like a charm. Thanks a ton!

    Cheers!
    ~g


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •