Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 2 of 2
  1. #1
    Senior Coder
    Join Date
    Apr 2003
    Location
    England
    Posts
    1,192
    Thanks
    5
    Thanked 13 Times in 13 Posts

    USB / HID on Vista

    I have been trying to get this to work on and off in my spare time for a few months. I think there is even an unanswered post on here about it.

    Does anyone know how to enumerate the human interface devices (HID) on windows Vista? I have tried just about everything I can (from C to C# etc.. as well as many different approaches) and it seems that any code I write will enumerate and communicate fine on XP but always, always, always enumerates to nothing on Vista.

    These attempts all boil down to hid.dll and setupapi.dll and using those 2 dlls via existing libraries or by the lowest level calls I can make always results in 0 devices found (while it finds them fine on XP).

    Are these dlls deprecated in Vista? Is there some replacement? Is it possible to communicate with a USB Human Interface Device in another way? (as a non-hid usb device or something similar?)

    Please reply if you have the slightest bit of information (even if it is just another forum, mailing list, newsgroup or whatever that I may get more help from). I have drawn a complete blank for months.
    Last edited by ghell; 10-21-2007 at 08:58 PM.

  • #2
    Rockstar Coder
    Join Date
    Jun 2002
    Location
    USA
    Posts
    9,074
    Thanks
    1
    Thanked 328 Times in 324 Posts
    If those calls worked in XP, in Vista do you have the UAC on? Perhaps you need to run your program as administrator to get access to that kind of system information?
    OracleGuy


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •