Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 3 of 3
  1. #1
    Senior Coder
    Join Date
    Jan 2005
    Location
    Memphis, TN
    Posts
    1,801
    Thanks
    8
    Thanked 131 Times in 129 Posts

    Opera font rendering : weird things happening

    The other day I downloaded Opera 8.5 for windows into my work computer.

    I have Opera 8.02 at home.

    here's the deal. at home everythings fine. Today I had to redo a whole site and started up with my usual:

    Code:
    body {
    font: .9em/1.3em tahoma, verdana, sans-serif;
    letter-spacing: .03em;
    color: #f9f9f9;
    }
    IE and FF play along just fine. Opera on the other hand obeyed the:

    font size
    line height
    letter spacing
    and
    color

    but it was not obeying the font-family selection. It was inserting some bold faced serif font in there even though I have my default set to Tahoma.

    On my page headings I had something like:
    Code:
    h1 {
    font: 1.3em verdana, sans-serif;
    }
    and it was choosing something SO-NOT verdana and not my default Tahoma. It was some deco looking font. Sans-serif true but nothing I had specified.

    Since I had to get the site up and runing I just closed Opera and kept working in IE and FF.

    Got it all up and running and went back and checked on it again and the headings looked great in that font whatever it was but the body text was a light weight thin serif font. Not the stocky bold it was at first.

    It's like it's randomly picking what it wants to use despite my specifying.

    So i went to a mac and looked at it Opera (not sure the version) and it was perfect. FF and Safari as well.

    Is it an 8.5 issue or something? is it my work PC? need to fix it as I test in all 3.

    gracias

    -alan
    Last edited by harbingerOTV; 05-26-2006 at 02:00 AM.
    Stop making things so hard on yourself.
    i is tugbucket :: help raise tugburg :: Whitehaven Kiwanis

  • #2
    Senior Coder
    Join Date
    Jan 2005
    Location
    Memphis, TN
    Posts
    1,801
    Thanks
    8
    Thanked 131 Times in 129 Posts
    So after playing with it some it turns out to be my PC at work. I downloaded the new version of Opera at home and it worked fine.

    Now for some more fun stuff.

    I went back to the same site the other day and it was a whole new set of font selections in Opera. So I went to other sites just to se. Yep Opera felt fit to replace the font on all pages with something on my computer. Looking at coding forums it had replaced the default with some "techy" matrix looking font. When looking at th eOpera system page it was all script.

    weirdness.

    anyone?
    Stop making things so hard on yourself.
    i is tugbucket :: help raise tugburg :: Whitehaven Kiwanis

  • #3
    Supreme Master coder! _Aerospace_Eng_'s Avatar
    Join Date
    Dec 2004
    Location
    In a place far, far away...
    Posts
    19,291
    Thanks
    2
    Thanked 1,043 Times in 1,019 Posts
    This has happened to me before. I think opera has a user stylesheet that might be enabled by default. Click on View > Styling > Set to author mode
    Last edited by _Aerospace_Eng_; 06-03-2006 at 11:09 PM.
    ||||If you are getting paid to do a job, don't ask for help on it!||||


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •