Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 8 of 8
  1. #1
    New to the CF scene
    Join Date
    Jun 2013
    Location
    Hell (AZ,Phoenix)
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Question Bottom of page getting cut off

    Hey every one.
    I am new to php and I am building a web page for fun on a home server I run. the pages seem to work fine on a computer web browser. I tried a few of them(IE, Firefox, Chrome, Safari) and they worked fine.
    but when I go to my site from my Iphone or my friends Iphone the bottom of the page gets cut off.
    I have two different pages.
    1,computer page.
    2, iphone page.
    and when you go to my site there is a redirect script to send the right browser to the right page.
    but when I type in the file location on the server for my iphone page it works fine on a computer browser. but not on the mobile Iphone browser (safari).
    plz any help would be great.
    Thanks Every One!


    Here is a link to the site: http://metrikcorp.co.nr/
    Here is the link to the Iphone version Mobile site: http://metrikcorp.co.nr/Iphone-Php-Mobile/index.php

    P.S: if you want to see the codes just let me know and I can send them to you.

  • #2
    God Emperor Fou-Lu's Avatar
    Join Date
    Sep 2002
    Location
    Saskatoon, Saskatchewan
    Posts
    16,994
    Thanks
    4
    Thanked 2,662 Times in 2,631 Posts
    Rendering problem will be an HTML/CSS issue, not a PHP issue. Especially so since it works on desktop browsers but not on mobile. First thing to check would be that it validates against the w3 html validator, and go from there.

    As for the second problem regarding the redirect, I would suggest that's also a problem unique to the device. If it works properly on desktop browsers using a 301/307 header, than it sounds like the iphone safari has a pisspoor implementation of the http specifications. That assumes of course that the redirection ruleset doesn't include anything to do with browser specific redirections. The only thing I can suggest is trying a different browser on the iphone, and I haven't a clue what's available for options.

    Doesn't sound like this has anything to do with PHP code itself. Moving to building for mobile devices forum.
    PHP Code:
    header('HTTP/1.1 420 Enhance Your Calm'); 
    Been gone for a few months, and haven't programmed in that long of a time. Meh, I'll wing it ;)

  • #3
    New to the CF scene
    Join Date
    Jun 2013
    Location
    Hell (AZ,Phoenix)
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thank you for the reply and the great info. I have tried different browser like chrome and Ibrowsfree. Still the same problem on mobile. But at least I know where to start the new search.
    And thanks for putting this in there right place to get help.

  • #4
    God Emperor Fou-Lu's Avatar
    Join Date
    Sep 2002
    Location
    Saskatoon, Saskatchewan
    Posts
    16,994
    Thanks
    4
    Thanked 2,662 Times in 2,631 Posts
    Is the HTML code identical for both the mobile and the desktop bases? I can't help much on the HTML fixes, but if they are different than that's a different problem (I assumed they were the same and used CSS media controls).
    PHP Code:
    header('HTTP/1.1 420 Enhance Your Calm'); 
    Been gone for a few months, and haven't programmed in that long of a time. Meh, I'll wing it ;)

  • #5
    New to the CF scene
    Join Date
    Jun 2013
    Location
    Hell (AZ,Phoenix)
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    They was. But I made some changes to the iPhone pages html to shrink it down. I just cut off the extra stuff that does not need to be on the iPhone page. But the css are totally different. If you would like give me an email or a IM and I can send you my codes and you can see them.
    Thanks for every thing guys.

  • #6
    New to the CF scene
    Join Date
    Jun 2013
    Location
    Hell (AZ,Phoenix)
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I and by the way. When I run it on my test server that is just on my network every thing works great. But once I put it on my live server the iPhone page no longer works.
    Hope that helps

  • #7
    New to the CF scene
    Join Date
    Jun 2013
    Location
    Hell (AZ,Phoenix)
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I have also try it on a Android emulator 3.4" WQVGA (240 x 432: idpi) web browser and it displays basically like i want it to.
    problem seems to only be with the iphone web browser(safari).
    still Searching every document i can find to try and fix the problem.
    and right now no my iphone page and computer page are not the same. i made a new page just for the iphone cause when i was using just one html/php (used media to pick css based on screen size) and using two different css i was having the same problem so i hoped that doing it separate would help with no success.
    (P.S I currently use Javascript to send the iphone web browser to the iphone page.)

  • #8
    New to the CF scene
    Join Date
    Jun 2013
    Location
    Hell (AZ,Phoenix)
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Well finally got it to work on the iphone web browse. the problem was in the css. so went over it again to see if there was any thing else that i could cut from the mobile site.
    Then i added
    Code:
    overflow:scroll;
    to the css and now every thing seems to be working
    .
    Lots more testing to go.


  •  

    Tags for this Thread

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •