Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 9 of 9
  1. #1
    New Coder
    Join Date
    Jan 2003
    Location
    N. Ireland
    Posts
    79
    Thanks
    0
    Thanked 0 Times in 0 Posts

    update database errors

    hi, im a newbie and im totally stuck with this uodate problem, i keep getting errrors no matter what i changeor do, the latest one being:
    Error Type:
    Microsoft JET Database Engine (0x80040E10)
    No value given for one or more required parameters.
    /MEMBERS/asp/editrecord.asp, line 51

    can anyone please help..?


    ska
    Last edited by skalag; 01-27-2003 at 10:40 PM.

  • #2
    Regular Coder
    Join Date
    Jun 2002
    Location
    Lake Forest, CA
    Posts
    259
    Thanks
    0
    Thanked 0 Times in 0 Posts
    The Wizzard
    OC Motor Cars | OC Auto Sports (Coming Soon!)

  • #3
    New Coder
    Join Date
    Jan 2003
    Location
    N. Ireland
    Posts
    79
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Smile

    Thanks very much for the time and help wizzard, it looks like one of the most explanatory tutorials i've seen, and believe me i've been through dozens in the last few weeks, so i'll see if i can get things working.

  • #4
    New Coder
    Join Date
    Jan 2003
    Location
    N. Ireland
    Posts
    79
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hello again, i have now managed to successfully update the database, thanks a lot wizzard, the only problem is that when i response.redirect to the display page it is blank, no records are shown, if anyone can help with this it would be much appreciated.
    Last edited by skalag; 01-27-2003 at 10:45 PM.
    ska

  • #5
    Senior Coder
    Join Date
    Jun 2002
    Location
    41° 8' 52" N -95° 53' 31" W
    Posts
    3,660
    Thanks
    0
    Thanked 0 Times in 0 Posts
    If you're just using Response.Redirect, then you're not giving the page any parameters to use.

    You'll either need to submit a form with hidden fields, or pass values in a querystring (the two most common methods), i.e.:

    Response.Redirect("something.asp?myvalue=" & myvalue)

    Can you give us some example code?
    Former ASP Forum Moderator - I'm back!

    If you can teach yourself how to learn, you can learn anything. ;)

  • #6
    New Coder
    Join Date
    Jan 2003
    Location
    N. Ireland
    Posts
    79
    Thanks
    0
    Thanked 0 Times in 0 Posts
    okay here's some code, I can see where it is going wrong, when I redirect to displayrec.asp it has no way of determining which recordset to select, the original sql was:
    strSQL = "SELECT * from tblpubdata where Fusername = '" & Request.form("Tusername") & "'"
    Last edited by skalag; 01-29-2003 at 01:58 AM.
    ska

  • #7
    Senior Coder
    Join Date
    Jun 2002
    Location
    41° 8' 52" N -95° 53' 31" W
    Posts
    3,660
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi,

    After reading your code, the problem is still this (as I stated above), for example:

    response.redirect("Displayrec.asp?Fid=" & lngRid)

    You are not passing any variables to the ASP page to parse.

    What you need to do is pass the info in the querystring as I posted above, and then get the variable from the querystring using:

    Request.QueryString()

    http://www.w3schools.com/asp

    At the very least the tutorials above will give you a solid foundation for ASP, I would read the whole tutorial there, that will solve a LOT of problems for you.
    Last edited by whammy; 01-28-2003 at 03:12 AM.
    Former ASP Forum Moderator - I'm back!

    If you can teach yourself how to learn, you can learn anything. ;)

  • #8
    New Coder
    Join Date
    Jan 2003
    Location
    N. Ireland
    Posts
    79
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks very much whammy, i can see what is going wrong, and following your instructions i have now sent the record id value back to display.asp, but my problem is i am using the "Fusername" as the unique identifier for the recset i am selecting and i am at a loss how to pass this back and retrieve it. i have just struggled through a login check to get this far and my code is all over the place, iam getting seriously lost..please help.
    Is it possible to set a session value for Fusername that can be accessed by any page requiring an identity for record selection? i have a very limited knowledge of code.
    ska

  • #9
    New Coder
    Join Date
    Jan 2003
    Location
    N. Ireland
    Posts
    79
    Thanks
    0
    Thanked 0 Times in 0 Posts
    OK, i have managed to fix the problem using a response.cookie value, its not he cleanest written code but it works, so thats a start. Thanks for the help guys, no doubt i'll be back when i try to addnew and delete, though hopefully it should be a little easier this time. Still its great to find an active forum with friendly people willing to help, thanks again..
    ska


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •