Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 4 of 4
  1. #1
    Regular Coder
    Join Date
    Jun 2002
    Posts
    905
    Thanks
    23
    Thanked 5 Times in 5 Posts

    phpdev apache problem with form variables

    Hey chaps ...

    Problem with Apache, that has been installed under the PHPdev 4 installer ...

    Can't seem to send variables using html forms. Tried using POST and GET methods but the following page cannot read the variables sent, they get sent empty. I have tested the forms elsewhere and they work fine. Just a simple text field sending one word. Infact when I click the submit button on the form it goes to the action file however the variables get stuck onto the URL in the address not and still do not get picked up by the page.

    Tried php HTTP_GET_VARS to try and recover the variables but no luck. As I said, I tried this form and others on my online host and they worked fine. So I'm thinking apache config issue? Can't see anything in conf file relating to this.

    If anyone has any advice that would be great.

    Regards,
    Sir P

  • #2
    Super Moderator
    Join Date
    May 2002
    Location
    Perth Australia
    Posts
    4,084
    Thanks
    11
    Thanked 99 Times in 97 Posts
    Hi , add method="POST" to your <form> tag
    resistance is...

    MVC is the current buzz in web application architectures. It comes from event-driven desktop application design and doesn't fit into web application design very well. But luckily nobody really knows what MVC means, so we can call our presentation layer separation mechanism MVC and move on. (Rasmus Lerdorf)

  • #3
    Regular Coder
    Join Date
    Jun 2002
    Posts
    905
    Thanks
    23
    Thanked 5 Times in 5 Posts
    hi again firepages, ok I had that but it wasnt quoted, so now it doesnt send the variables to the URL however still doesnt seem to send anything .. something as simple as ...
    Code:
    <form id="form1" name="form1" action="testr.php" method="POST">
      <input name="test" type="text" id="test" />
      <input type="submit" name="Submit" value="test" />
    </form>
    just doesnt send anything in a variable... any thoughts?

    Also I had to find phpdev online as bandwidth was down for yer site, I noticed that a couple of months ago aswell, do you need a mirror to host it? I would be more than happy to offer a mirror for phpdev if you are continuing with it.

  • #4
    Regular Coder
    Join Date
    Jun 2002
    Posts
    905
    Thanks
    23
    Thanked 5 Times in 5 Posts
    ok i just removed phpdev4 and installed phpdev5 .. and have exactly the same problem.. with forms that I know to be working ... random.

    Really stump'd on this 'un


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •